[R6RS] Renaming write-...
Anton van Straaten
anton at appsolutions.com
Tue Aug 1 13:39:35 EDT 2006
Michael Sperber wrote:
You're a genius!
I've checked in an updated version of
draft/corelib/library-contents.html (and library-index.html), which
contains the following changes:
* The "r5rs-i/o" library has been renamed to "simple-i/o". (It's
shorter than "convenient-i/o"; better name suggestions welcome. Any
takers for "ezio"?)
* The procedures read-char, write-char, and peek-char have been added to
the simple-i/o library.
* In the port-i/o library, all read-... and write-... procedures have
been renamed to get-... and put-... respectively. This list includes
get-datum and put-datum. peek-char and peek-u8 have been renamed to
poll-char and poll-u8.
* I have not moved get-datum and put-datum to a separate library, as I
think Mike suggested in an earlier email. If we're really going to do
that, perhaps we should consider flushing them, since IIUC, they only
differ from 'read' and 'write' in that their port argument is not optional.
More information about the R6RS