[R6RS] Naming for fixnum / flonum ops

William D Clinger will
Mon Jul 11 12:42:43 EDT 2005

I prefer the fx+ and fxquotient style of name.

As for why these should be in the core rather than in a library:
I believe the idea is that the R6RS would require all systems to
provide these operations, albeit with a semantics parameterized
by a system-dependent fixnum range.  The R5RS-style operations
would then go into a library, for which we expect to provide a
portable implementation.

Note that the R6RS editors have not agreed to include R5RS-style
+ in the R6RS, so thinking of fx+ as a specialization of + is not


More information about the R6RS mailing list