Mon Apr 12 17:18:24 EDT 2004
At Mon, 12 Apr 2004 20:43:16 +0200, Michael Sperber wrote:
> >>>>> "Matthew" == Matthew Flatt <mflatt at cs.utah.edu> writes:
> Matthew> Quoting Mike:
> >> I also strongly vote for calling the basic construction something
> >> other than "module," "package," or "unit," to avoid the traditional
> >> confusion.
> I may have expressed this poorly. I vote for calling it something
> *not* in the above set
Ah - that's clearly what you wrote, and I mis-read it.
> I realize this is kind of radical, but otherwise, we're just going to
> get into the same endless wars again: "How could the R6RS people f*ck
> up the module system? It doesn't even support X." Then at least we
> could reply: "R6RS doesn't specify a module system---it only specifies
> a frob system. A module system is still useful, and it's
> implementable via the frob system / is addressed by library X or SRFI
> Y / may be addressed by RZRS."
I'm skeptical that an unusual term will avoid this problem. People will
merely start "Scheme's modules are called `frobs'... and we note that
this `frob' module system doesn't support X".
More information about the R6RS