Mon Apr 12 13:27:59 EDT 2004
In principle, we're now discussing "modules", right?
Do we all agree with Mike's characterization of "module" for our
If we don't agree, we should probably figure that out fast.
Otherwise, perhaps I need to work harder o provoke comments on the
strawman syntax proposal.
Here's the only one I find so far:
> I also strongly vote for calling the basic construction something
> other than "module," "package," or "unit," to avoid the traditional
I'm not eager to change the term, but I won't fight against it. How
many other people prefer to change the term?
"Package" is ok with me. It clashes only slightly with Java's use of
"Unit" seems occupied already to me (for obvious reasons), and
"component" for the same reason.
"Library"? PLT Scheme currently uses the term "library" for a module
that's in a standard place. A group of library modules is a
"collection". (This terminology shows up in the strawman syntax
proposal, in the form of s `lib' path spec.) I like this arrangement,
but it may not be important to have such distinct terms.
More information about the R6RS